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Preface
 

Purpose of This Manual

This guide describes the features of FUJITSU Software Development Tools (referred to as "FSDT" in this guide) and explains how to use
it.

 
Intended Readers

This guide is intended for those who develop programs using FSDT. It is assumed that readers of this guide are familiar with developing
programs.

 
Organization of this Guide

Chapter 1 Overview of FSDT

Provides an overview of FSDT

Chapter 2 Basic Flow for Developing Applications

Explains the basic flow for developing application programs using FSDT

Chapter 3 Login Feature

Explains how to log in to the login node from FSDT

Chapter 4 Launcher Feature

Explains how to start each FSDT feature

Chapter 5 File Operating Feature

Explains how to operate files using the File explorer

Chapter 6 File Editing Feature

Explains how to edit files using the Editor

Chapter 7 Application Builder Feature

Explains how to create applications

Chapter 8 Application Executor Feature

Explains how to execute applications

Appendix A Considerations for Using FSDT

Describes the key points to consider when using FSDT features

Appendix B Shortcut Keys List

Lists the shortcut keys available in FSDT

 
Syntax description symbols

A syntax description symbol is a symbol that has specific meaning in syntax. The following symbols are used in this guide.

 
Symbol name Symbol Description

Selection symbol
{ } Indicates that only one of the enclosed items can be selected

| Is used as a delimiter in a list of items

Optional symbol [ ]

Indicates that the enclosed item can be omitted

The { } (braces selection symbol) and [ ] (brackets optional symbol) have the same
meaning.

Default symbol
_

(underline)

Indicates the default value when all items enclosed in [ ] (brackets optional symbol) are
omitted
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Symbol name Symbol Description

Repeat symbol ... Indicates that the item just before this symbol can be specified repeatedly

 
Export Controls

Exportation/release of this document may require necessary procedures in accordance with the regulations of your resident country
and/or US export control laws.

 
Trademarks
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and/or other countries.
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Copyright

Copyright FUJITSU LIMITED 2014
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Chapter 1 Overview of FSDT
This chapter describes the features and basic concepts of FSDT.

1.1 Introduction
FSDT is a GUI development environment that supports various phases of application program development.

It provides advanced development tools such as the File explorer, the Editor, the Debugger, and the Profiler.

1.2 FSDT Components
FSDT consists of a GUI on the user terminal and a login node processing unit (Web service program) on the login node.

GUI

The GUI provides the development support features of FSDT. Using the GUI, you can create, edit, compile, and execute programs.

Login node processing unit

The login node processing unit is a Web service program for processing on the login node. It can be accessed from the GUI.

1.3 FSDT Features
FSDT features are described below.

 
Table 1.1 FSDT features

Feature Description

Login feature Displays the Login window to log in to the login node and start the main window of FSDT

Launcher feature Displays the main window with all FSDT features

- File operating feature (File explorer)

- File editing feature (Editor)

- Application builder feature (Builder)

- Application executor feature (Executor)

- Debugging feature (Debugger)

- Profiling feature (Profiler)

File operating feature Provides the File explorer that enables file creation/operation

File editing feature Provides the Editor that enables content display/editing

Application builder feature Provides the Builder that enables application creation

Application executor feature Provides the Executor that supports application execution

Debugging feature Provides the Debugger that enables application debugging

Profiling feature Provides the Profiler that enables application tuning
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Chapter 2 Basic Flow for Developing Applications
This chapter describes the basic flow for developing application programs using FSDT.

2.1 Preparation

2.1.1 Install FSDT
Install FSDT in the user terminal.

1. Display "User GUI install page" in web browser of the user terminal.

Please contact the system administrator about URL of this page.

2. Click [Download Now] button at "User GUI install page".

The installer will be downloaded in the user terminal.

3. Execute the installer and install.

Please refer "User GUI install page" for next step.

Figure 2.1 User GUI install page

 

 Note

"<VL>" is the version of the FJSVmxlang package.

Moreover, the uninstallation can be done in the control panel or "User GUI install page".
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2.2 Development

2.2.1 Start FSDT
Start FSDT to display the main window in the user terminal.

1. Run FUJITSU Software Development Tools on the user terminal.

The Login window will be displayed.

2. Specify IP address or hostname of the login node, username/password of the login account. Click Ok button.

If the authentication is successful, the main window appears.

Figure 2.2 Login window

Figure 2.3 Main window

2.2.2 Create a Program
This section explains how to create a program using FSDT.

2.2.2.1 Create a File
Create a file using the File explorer.

1. Click the File explorer icon in the main window.

The File explorer window will be displayed.

2. In the tree area of the File explorer window, select the folder where the file is to be created. On the menu bar, click File > New >
File.

A file node is displayed as selected in the list area.

- 3 -



3. Change the name of the selected file to provide a meaningful name.

A new file is created.

Refer to "Chapter 5 File Operating Feature" for information on the File explorer.

Figure 2.4 File explorer icon

Figure 2.5 File explorer window

2.2.2.2 Edit a File
Edit a file by using the Editor.

1. Click the Editor icon in the main window.

The Editor window will be displayed.
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2. On the menu bar, click File > Open ....

The file chooser window will be displayed.

3. Specify a filename, and then click Open.

The file will be displayed in the Editor.

Refer to "Chapter 6 File Editing Feature" for information on the Editor.

Figure 2.6 Editor icon

Figure 2.7 File chooser window
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Figure 2.8 Editor window

2.2.3 Build the Application
This section explains how to build an application using FSDT.

2.2.3.1 Create a makefile
Create a makefile by using the File explorer and the Editor on the login node.

2.2.3.2 Execute the make command
Execute the makefile using the make command in the Builder.

1. Click the Builder icon in the main window.

The Console window with make tab selected will be displayed.

2. Specify the argument for the make command in the Command box, and then click Enter.

The make command is executed.

Refer to "Chapter 7 Application Builder Feature" for information on the make tab in the Console window.
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Figure 2.9 Builder icon

Figure 2.10 Console window (make tab is selected)

2.2.4 Execute the Application
This section explains how to execute an application using FSDT.

2.2.4.1 Generate a Script for Application Execution
Generate a script for application execution on the login node by using the File explorer and the Editor.

2.2.4.2 Submit the Script as a Job
Submit the script for application execution as a job using the Executor.

1. Click the Executor icon in the main window.

The Console window with the job tab selected will be displayed.

2. Specify the argument for the pjsub command in the Command box, and then click Enter.

The pjsub command is executed.
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Refer to "Chapter 8 Application Executor Feature" for information on the Executor.

Figure 2.11 Executor icon

Figure 2.12 Console window (job tab is selected)

2.2.5 Debug the Application
Debug the application by using the Debugger.

1. Click the Debugger icon in the main window.

The Debugger window (Debugger start setting) will be displayed.

Refer to the "Debugger User's Guide" for information on the Debugger.
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Figure 2.13 Debugger icon

Figure 2.14 Debugger window (Debugger start setting)

2.2.6 Perform the Tuning of the Application
Perform the tuning of the application by using the Profiler.

1. Click the Profiler icon in the main window.

The Profiler window (Data chooser window) will be displayed.

Refer to the "Profiler User's Guide" for information on the Profiler.
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Figure 2.15 Profiler icon

Figure 2.16 Profiler window (Data chooser window)
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Chapter 3 Login Feature
This chapter describes the login feature of FSDT.

3.1 Accessing the Login Window
The login feature provides the Login window to log in to the login node and display the main window of FSDT.

1. Click FUJITSU Software Development Tools on the Start menu of the user terminal to display the Login window.

3.2 Login Window Elements
The Login window comprises the following elements:

Figure 3.1 Login window

 
(1)Header Area

The window title, "Login", is displayed in the header area.

 
(2)Input Area

The following input items are displayed in the input area.

 
Table 3.1 Input items (Login window)

Name Description

Server Specify the IP address or host name of the login node.

Name Specify a username of the login account.

Password Specify a password of the login account.

Save login information Select this check box to save the server and name information.

 
(3)Buttons Area

The following buttons are displayed in the buttons area.

 
Table 3.2 Buttons (Login window)

Name Description

Ok Uses the information provided in the input area for login

If the login succeeds, the Login window is closed and the main window is displayed.

Cancel Closes the Login window
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3.3 Usage Considerations
Refer to "A.1 Login Feature" in "Appendix A Considerations for Using FSDT" for information on the considerations for using the Login
feature.
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Chapter 4 Launcher Feature
This chapter describes the launcher feature of FSDT.

4.1 Launcher Feature
The launcher feature provides the main window that starts all FSDT features.

- File operating feature (File explorer)

- File editing feature (Editor)

- Application builder feature (Builder)

- Application executor feature (Executor)

- Debugging feature (Debugger)

- Profiling feature (Profiler)

1. In the Login window, specify the IP address or host name of the login node, username/password of the login account, and then click
Ok button.

If the authentication succeeds, the main window is displayed.

Refer to "Chapter 3 Login Feature" for information on the Login window.

4.2 Main Window Elements
The main window comprises the following elements:

Figure 4.1 Main window

 
(1)Icon Area

The icons that start each FSDT feature are provided in the icon area.

You can start a feature by simply clicking the relevant icon. Move the pointer over an icon to view the feature it represents.

The following icons are displayed in the icon area.

 
Table 4.1 Icons (main window)

Icon Description

File explorer Displays the File explorer

Editor Starts the Editor
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Icon Description

Builder Starts the Builder

Executor Starts the Executor

Debugger Starts the Debugger (Debugger start setting window)

Profiler Starts the Profiler (Data chooser window)

Additionally, a pop-up menu is displayed on right-click.

The following commands are displayed on the pop-up menu.

 
Table 4.2 Pop-up menu (main window)

Name Description

File Exit Closes the main window and exits FSDT

View Always on top Select this check box to display the main window always on the top

Tools File explorer Displays the File explorer

Editor Starts the Editor

Builder Starts the Builder

Executor Starts the Executor

Debugger Starts the Debugger (Debugger start setting window)

Profiler Starts the Profiler (Data chooser window)

Help About Displays information about FSDT

 
(2)Footer Area

The window title, "FUJITSU Software Development Tools", is displayed in the footer area.

4.3 Usage Considerations
Refer to "A.2 Launcher Feature" in "Appendix A Considerations for Using FSDT" for information on the considerations for using the
launcher feature.
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Chapter 5 File Operating Feature
This chapter describes the file operating feature of FSDT.

5.1 File Operating Feature
The file operating feature provides the File explorer that assists in creating and operating files.

1. To start the File explorer, click the File explorer icon in the main window.

Doing this displays the File explorer window.

Refer to "Chapter 4 Launcher Feature" for information on the main window.

Figure 5.1 File explorer icon

5.2 File Explorer Window Elements
The File explorer window comprises the following elements:
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Figure 5.2 File explorer window

 
(1)Header Area

The window title, "File explorer", is displayed in the header area.

 
(2)Menu Bar

The menu bar enables various File explorer features.

 
Table 5.1 Menu bar (File explorer window)

Name Description

File Open Opens the selected file in the Editor

New File Creates a new file

Folder Creates a new folder

Delete Deletes the selected item

Rename Renames the selected item

Exit Closes the File explorer window

Edit Copy Copies the selection to the Clipboard

Paste Pastes the file or folder from the Clipboard

View Select listing view
columns ...

Displays the SelectColumns where you can select the check boxes for the columns you
want to display in the list area

Refresh Updates the information in the list area

 
(3)Tree Area

The tree area displays the folder structure of the user terminal and the login node.
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(4)List Area

The list area displays the contents of the folder selected in the tree area in a list. Click a column header to sort its contents.

Additionally, a pop-up menu is displayed on right-click.

The following commands are displayed on the menu.

Note that these commands are displayed depending on whether an item is selected or not.

 
Table 5.2 Pop-up menu (List area, no selection)

Name Description

Refresh Same functionality as View > Refresh on the menu bar

Paste Same functionality as Edit > Paste on the menu bar

New File Same functionality as File > New > File on the menu bar

Folder Same functionality as File > New > Folder on the menu bar

 
Table 5.3 Pop-up menu (List area, item selected)

Command Description

Open Same functionality as File > Open on the menu bar

Copy Same functionality as Edit > Copy on the menu bar

Delete Same functionality as File > Delete on the menu bar

Rename Same functionality as File > Rename on the menu bar

5.3 Usage Considerations
Refer to "A.3 File Operating Feature" in "Appendix A Considerations for Using FSDT" for information on the considerations for using
the file operating feature.
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Chapter 6 File Editing Feature
This chapter describes the file editing feature of FSDT.

6.1 File Editing Feature
The file editing feature provides the Editor that enables you to view/edit content.

1. To start the Editor, click the Editor icon in the main window.

Doing this displays the Editor window.

Refer to "Chapter 4 Launcher Feature" for information on the main window.

Figure 6.1 Editor icon

6.2 Editor Window Elements
The Editor window comprises the following elements:
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Figure 6.2 Editor window

 
(1)Header Area

The window title, "Editor", is displayed in the header area.

 
(2)Menu Bar

The menu bar enables various Editor features.

 
Table 6.1 Menu bar (Editor window)

Name Description

File New Opens a new tab

Open ... Opens the file specified in the file chooser window in the Editor

Save Saves the file being edited

Save as ... Saves the file being editing with the name specified in the file chooser window

Exit Closes the Editor

Edit Cut Deletes the selection and saves it to the Clipboard

Copy Copies the selection to the Clipboard

Paste Pastes content from the Clipboard

Find ... Searches for the specified keyword

Tools Options ... Displays the Options window where you can configure settings for the Editor
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Figure 6.3 File chooser window

 
(3)View Area

The view area consists of the file tab, file path area, line number area, and text area.

The name of the file open in the text area is displayed on the file tab.

You can close the file tab by clicking the Close icon on the tab.

The full path and the status of the file displayed in the text area are provided in the file path area. In the file status information, "modified"
means that the file is currently being edited and "read only" means the read-only attribute.

The file content is displayed and edited in the text area.

Additionally, a pop-up menu is displayed on right-click.

The following commands are displayed on the menu.

 
Table 6.2 Pop-up menu (Editor window)

Name Description

Cut Same functionality as Edit > Cut on the menu bar

Copy Same functionality as Edit > Copy on the menu bar

Paste Same functionality as Edit > Paste on the menu bar

6.3 Shortcut
Keyboard shortcuts are also available for some Editor features.

Refer to "Appendix B Shortcut Keys List" for information on the shortcut keys that can be used in the Editor.

6.4 Option
You can change the text display settings of the Editor by using the Options window.
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Click Tools > Options ... on the menu bar to display the Options window.

The following items can be set in this window.

 
Table 6.3 Editor option

Name Description

Font Text font size Specify a size for the text.

Text font Specify a font for the text.

Text font style Specify a style for the text.

Figure 6.4 Options window (Editor window)

6.5 Usage Considerations
Refer to "A.4 File Editing Feature" in "Appendix A Considerations for Using FSDT" for information on the considerations for using the
file editing feature.
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Chapter 7 Application Builder Feature
This chapter describes the application builder feature of FSDT.

7.1 Application Builder Feature
The application builder feature uses the File explorer and the Editor to create a makefile, and then uses the Builder to execute the make
command.

This section explains how to build an application using FSDT.

7.1.1 Create a makefile
Create a makefile by using the File explorer and the Editor on the login node.

Refer to "Chapter 5 File Operating Feature" for information on the File explorer.

Refer to "Chapter 6 File Editing Feature" for information on the Editor.

7.1.2 Execute the make command
Execute the make command in the Builder to process the makefile.

1. Click the Builder icon in the main window.

The Console window with the make tab selected will be displayed.

2. In the Command area, specify the argument for the make command, and then click Enter.

Doing this executes the make command.

Refer to "Chapter 4 Launcher Feature" for information on the main window.

Figure 7.1 Builder icon

7.2 Console Window Elements
The Console window comprises the following elements:
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Figure 7.2 Console window (make tab is selected)

 
(1)Header Area

The window title, "Console", is displayed in the header area.

 
(2)Menu Bar

The menu bar enables Console features.

 
Table 7.1 Menu bar (Console window)

Name Description

File Exit Closes the Console window

 
(3)make Tab

The Command area and the response area are displayed on the make tab.

The argument for the make command or the executed folder can be specified in the Command area.

Click Enter to execute the command.

The argument for the make command or the history of the executed folder can be referred to/specified using the combo box. Up to 10
latest history items are maintained and duplicate information is not retained.

The character string of the executed command and the response are displayed in the response area.

Additionally, a pop-up menu is displayed on right-click.

The following commands are displayed on the menu.

 
Table 7.2 Pop-up menu (Console window)

Name Description

Copy Copies the selected character strings to the Clipboard

Clear Deletes all character strings

SelectAll Selects all character strings
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(4)Footer Area

The status information is displayed in the footer area.

 
Table 7.3 Status information (Console window)

Name Description

RUNNING... Indicates that the command is being executed

7.3 Usage Considerations
Refer to "A.5 Application Builder Feature" in "Appendix A Considerations for Using FSDT" for information on the considerations for
using the application builder feature.
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Chapter 8 Application Executor Feature
This chapter describes the application executor feature of FSDT.

8.1 Application Executor Feature
The application executor feature uses the File explorer and the Editor to create a script for application execution, and then uses the Executor
to submit the script as a job.

This section explains how to execute an application using FSDT.

8.1.1 Create a Script for Application Execution
Create a script for application execution on the login node by using the File explorer and the Editor.

Refer to "Chapter 5 File Operating Feature" for information on the File explorer.

Refer to "Chapter 6 File Editing Feature" for information on the Editor.

8.1.2 Submit the Script as a Job
Submit the script for application execution as a job by using the Executor.

1. Click the Executor icon in the main window.

The Console window with the job tab selected will be displayed.

2. In the Command area, specify the argument for the pjsub command, and then click Enter.

Doing this executes the pjsub command.

Refer to "Chapter 4 Launcher Feature" for information on the main window.

Figure 8.1 Executor icon

8.2 Console Window Elements
The Console window comprises the following elements:
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Figure 8.2 Console window (job tab is selected)

 
(1)Header Area

The window title, "Console", is displayed in the header area.

 
(2)Menu Bar

The menu bar enables Console features.

 
Table 8.1 Menu bar (Console window)

Name Description

File Exit Closes the Console window

 
(3)job Tab

The Command area and the response area are displayed on the job tab.

The executed command (pjsub/pjstat/pjdel), the command argument, or the executed folder can be specified in the Command area.

Click Enter to execute the command.

The argument for the executed command or the history of the executed folder can be referred to/specified using the combo box. Up to 10
latest history items are maintained and duplicate information is not retained.

The character string of the executed command and the response are displayed in the response area.

Additionally, a pop-up menu is displayed on right-click.

The following commands are displayed on the menu.

 
Table 8.2 Pop-up menu (Console window)

Name Description

Copy Copies the selected character strings to the Clipboard

Clear Deletes all character strings

SelectAll Selects all character strings
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(4)Footer Area

The status information is displayed in the footer area.

 
Table 8.3 Status information (Console window)

Name Description

RUNNING... Indicates that the command is being executed

8.3 Usage Considerations
Refer to "A.6 Application Executor Feature" in "Appendix A Considerations for Using FSDT" for information on the considerations for
using the application executor feature.
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Appendix A Considerations for Using FSDT
This chapter describes the considerations for using various FSDT features.

A.1 Login Feature
 

Prepare the login account

If the available login account is unknown, please contact the system administrator.

 
Server certificate

If a warning window is displayed, the server certificate of the login node may be unreliable. Contact the system administrator.

A.2 Launcher Feature
No considerations apply.

A.3 File Operating Feature
 

Character code (line feed character)

The character code (line feed character) of a file is not changed during file transfer between the user terminal and the login node.

 
File name, file path

The following special characters and the blank character cannot be used in a file name/file path.

\/,;:*?"<>|$#!@&'()^[]{}`

 
User terminal folders without the read permission

When a user terminal folder that does not have the read permission is displayed in the list area, a message informing that such a folder
exists is not displayed.

 
File transfer

Files exceeding 20 MB cannot be copied across the user terminal or the login node.

A.4 File Editing Feature
 

Character code (line feed character)

The character code (line feed character) used for file read/write is UTF-8 (LF).

 
Displaying time

Files exceeding 2 MB cannot be used because they take time to display.

If any of the following operations are performed on a file that is 2 MB or less, it may take almost 3 seconds to display.

- Resize window

- Scroll

- Move the cursor

- Key input

- Open
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- Save

- Cut

- Paste

A.5 Application Builder Feature
 

Command area on the make tab in the Console window

The following special characters cannot be used in the Command area.

Input area for the command argument:

\;<>|$&'()`#!

Input area for the execution folder:

\,;:*?"<>|$#!@&'()^[]{}` blank character

 
Environment variable settings

To use the application builder feature, the following environment variables must be correctly set in a makefile.

 
Table A.1 Environment variables

Variable Value to be set

PATH /opt/FJSVmxlang/bin

LD_LIBRARY_PATH /opt/FJSVmxlang/lib64

 
Command paths

If a command path is unknown, contact the system administrator.

A.6 Application Executor Feature
 

Command area on the job tab in the Console window

The following special characters cannot be used in the Command area.

Input area for the command argument:

\;<>|$&'()`#!

Input area for the execution folder:

\,;:*?"<>|$#!@&'()^[]{}` blank character

 
Environment variable settings

To use the application executor feature, the following environment variables must be correctly set in a script for application execution.

 
Table A.2 Environment variables

Variable Value to be set

PATH /opt/FJSVmxlang/bin

LD_LIBRARY_PATH /opt/FJSVmxlang/lib64

To use the batch queuing system or the MPI system, additional settings besides those mentioned above may be necessary. Refer to the
"Job Operation Software manual" for information on the batch queuing system. Refer to the "MPI User's Guide" for information on the
MPI system.
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Interactive jobs

Interactive jobs cannot be used.

If an interactive job is submitted, delete the job.

 
Command paths

If a command path is unknown, contact the system administrator.
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Appendix B Shortcut Keys List
In this document, shortcut keys are specified as [modifier]+[key_name] where [modifier] is the key specified in the following table.

 
Table B.1 Modifiers

[modifier] Description

C Ctrl key

For example, C+A means that both the A key and the Ctrl key must be pressed simultaneously.

Shortcut keys that can be used in the Editor are given below.

 
Table B.2 Shortcut keys for the Editor (Windows)

Function Key combination

File > New on the menu bar C+N

File > Open ... on the menu bar C+O

File > Save on the menu bar C+S

Edit > Cut on the menu bar C+X

Edit > Copy on the menu bar C+C

Edit > Paste on the menu bar C+V

Edit > Find ... on the menu bar C+F

Move the cursor to the right of the current position RIGHT Arrow key

Move the cursor to the left of the current position LEFT Arrow key

Move the cursor upward from the current position UP Arrow key

Move the cursor downward from the current position DOWN Arrow key

Move the cursor to the start of a line HOME

Move the cursor to the end of a line END

Move the cursor to the start of a file C+HOME

Move the cursor to the end of a file C+END

Delete one character just after the cursor DELETE

Delete one character just before the cursor BACKSPACE

Insert a line feed character at the current position ENTER

Insert a TAB space at the current position TAB

 
Table B.3 Shortcut keys for the Editor (Macintosh)

Function Menu Key combination

File > New on the menu bar - command+N or C+N

File > Open ... on the menu bar - command+O or C+O

File > Save on the menu bar - command+S or C+S

Edit > Cut on the menu bar Edit > Cut command+X

Edit > Copy on the menu bar Edit > Copy command+C

Edit > Paste on the menu bar Edit > Paste command+V

Edit > Find ... on the menu bar - command+F or C+F

Select all Edit > Select All command+A

Move the cursor to the right of the current position - RIGHT Arrow key
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Function Menu Key combination

Move the cursor to the left of the current position - LEFT Arrow key

Move the cursor upward from the current position - UP Arrow key

Move the cursor downward from the current position - DOWN Arrow key

Move the cursor to the start of a line - HOME

Move the cursor to the end of a line - END

Move the cursor to the start of a file - C+HOME

Move the cursor to the end of a file - C+END

Delete one character just after the cursor - fn+DELETE

Delete one character just before the cursor - DELETE

Insert a line feed character at the current position - ENTER

Insert a TAB space at the current position - TAB

For Macintosh, in the following user's guide, replace the "right-click" action with "click while holding down the Ctrl key".

- Programming Workbench User's Guide

- Debugger User's Guide

- 32 -


	Title Page
	Preface
	Contents
	Chapter 1 Overview of FSDT
	1.1 Introduction
	1.2 FSDT Components
	1.3 FSDT Features

	Chapter 2 Basic Flow for Developing Applications
	2.1 Preparation
	2.1.1 Install FSDT

	2.2 Development
	2.2.1 Start FSDT
	2.2.2 Create a Program
	2.2.2.1 Create a File
	2.2.2.2 Edit a File

	2.2.3 Build the Application
	2.2.3.1 Create a makefile
	2.2.3.2 Execute the make command

	2.2.4 Execute the Application
	2.2.4.1 Generate a Script for Application Execution
	2.2.4.2 Submit the Script as a Job

	2.2.5 Debug the Application
	2.2.6 Perform the Tuning of the Application


	Chapter 3 Login Feature
	3.1 Accessing the Login Window
	3.2 Login Window Elements
	3.3 Usage Considerations

	Chapter 4 Launcher Feature
	4.1 Launcher Feature
	4.2 Main Window Elements
	4.3 Usage Considerations

	Chapter 5 File Operating Feature
	5.1 File Operating Feature
	5.2 File Explorer Window Elements
	5.3 Usage Considerations

	Chapter 6 File Editing Feature
	6.1 File Editing Feature
	6.2 Editor Window Elements
	6.3 Shortcut
	6.4 Option
	6.5 Usage Considerations

	Chapter 7 Application Builder Feature
	7.1 Application Builder Feature
	7.1.1 Create a makefile
	7.1.2 Execute the make command

	7.2 Console Window Elements
	7.3 Usage Considerations

	Chapter 8 Application Executor Feature
	8.1 Application Executor Feature
	8.1.1 Create a Script for Application Execution
	8.1.2 Submit the Script as a Job

	8.2 Console Window Elements
	8.3 Usage Considerations

	Appendix A Considerations for Using FSDT
	A.1 Login Feature
	A.2 Launcher Feature
	A.3 File Operating Feature
	A.4 File Editing Feature
	A.5 Application Builder Feature
	A.6 Application Executor Feature

	Appendix B Shortcut Keys List

